Alducks.com
http://alducks.com/board/

Motor problems??
http://alducks.com/board/viewtopic.php?f=1&t=39040
Page 1 of 1

Author:  MALIKWOODARDDEERDUCK [ July 20th, 2017, 5:58 pm ]
Post subject:  Motor problems??

I have been having some issues with my motor and hope that maybe someone can answer. I have cleaned the carbs, fuel tank, replaced the filter, and replaced the fuel lines. I have had no luck. It will run great until it warms up, then it will cut out and act like it's starving for fuel. I'll choke it and it will run like a top again for a minute. It runs fine if I'm not running full throttle. It will idle great and then have a hiccup and then go back to normal. Any ideas?? Fuel pump? Stator? Plugs?

Author:  bama [ July 24th, 2017, 1:20 pm ]
Post subject:  Re: Motor problems??

could be leak. A hose with a hole will suck air into system only when pushed. It could idle great and then when it tries to suck a bunch of gas it gets too much air.

IF you pump the bulb will it continue to run at speed?

if NOT it could be that or electronic not adjusting when throttle is applied.

Author:  band_collector7184 [ July 25th, 2017, 6:54 am ]
Post subject:  Re: Motor problems??

Put a brand new 22hp predator vtwin on my go-devil Long tail frame.pretty much ran the same way.idled fine but as far as running it would starve for fuel unless you squeezed the bubble every few seconds.evidently the vacuum fuel pump has a hard time keeping a vacuum when the fuel line is longer than 15in according to predator. so I got a 2-4psi electric fuel pump

Author:  Vizsla Winston [ August 3rd, 2017, 7:59 am ]
Post subject:  Re: Motor problems??

What kind of motor? I had a 150 Yamaha VMAX EFI acting that way and it was the low pressure fuel pumps not pulling enough fuel into the high pressure fuel pump reservoir. Also had a carbed 11hp pressure washer doing that, choke and all, and I ended up buying a new carb and it fixed the issue. And I had a 23hp vanguard on a zero turn John Deere mower cutting out once and it ended up being the fuel cap vent was clogged, so after a few minutes the tank would start to suck in from vacuum then the engine would cut out.

Author:  doughboy62869 [ October 2nd, 2017, 1:21 pm ]
Post subject:  Re: Motor problems??

i recommend running on gas that has no ethonal pure gas 10% ethonal blend will go bad quick

Author:  bama [ October 3rd, 2017, 7:33 am ]
Post subject:  Re: Motor problems??

I have over 230 hours on my Pro-Drive (2008 model) and 235,000 on my 1997 Tahoe.

I have never cared about kind of gas. I have had ZERO issues!

I know other people who went WAY out of their way to get REAL GAS. One time he got water in his tank and another guy had to replace all his fuel lines in less than 2 years.

I put Seafoam in every tank in my boat and in my cars about one time a month.

When Duck season is over I pour that gas in my mower. If it sits for very long I add Stabil.

Don't over think this

Author:  stevena198301 [ October 3rd, 2017, 12:41 pm ]
Post subject:  Re: Motor problems??

Had this issue with a 9.9 (or so I thought). Turned out being a combination of a gasket missing from the fuel filter assembly, and a non-vented gas cap. Once it'd get to the point the fuel was having problems coming in (due to the vacuum of the tank), the missing gasket allowed air to come in easier than the fuel from the tank. I figured out the gas cap issue quickly, and just don't screw it all the way down. The gasket took a while longer. It wouldn't leak, just suck in air, if the tank created a vacuum. I finally realized a gasket was missing by looking at the exploded diagram of the motor. Had there been a leak, I'd have noticed it much sooner. I just thought when I pulled the fuel filter bowl off, it was staying in the housing. Just a couple things to look at.

Page 1 of 1 All times are UTC - 6 hours [ DST ]
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/